What to do if robots are playing too slow?

Simulation speed depends on many points.
Simulation was running at speeds with factor 0.7 to 1.0 of real time in our experiments with average laptop computer and this is relatively high result between other similar cases.
Simulation speed is displayed in upper text window of Webots:


by digits 0.00x
If speed of simulation stays between 0.7 and 1.0 and sometimes drop to lower values for short time then this is regular performance of simulation.
If this speed is too low for some reasons there is opportunity to increase simulation speed by click to fast simulation button : fast-button
But in fast simulation mode real time factor can jump sharply to values over 2.0 with unnecessary effects leading to falling of robots. Auto Referee limits maximum speed of simulation programmaticaly with value 1.0 in order to avoid non-realistic behaviour of simulation.
Modern computers with Intel i7 and high quality grafic card can support simulation with real time speeds.
If you use computer with weak performance and simulation runs under speed factor 0.3 then following measures can help in achieving better results:

  • turning off shadow rendering. Tools/Preferences/OlenGL/Disable shadows

  • reducing of FPS from 60 to 30. In scene tree: Worldinfo/FPS

  • disconnecting from local networks LAN or Wifi

  • check in system task manger which background programs take resource of processor and grafic card. There could be some unnecessary programs running in in memory, for example some video processing agents.

  • Effective but not convenient method: turning off rendering by button: rendering-button
    Also be aware that multiple collisions between robots reduce speed of simulation due to comlex calculations.

Good luck!